Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 05-06-2022, 04:25 PM   #1
Hardbody92
 
Hardbody92's Avatar
 
Join Date: Jan 2013
Location: South West Florida
Posts: 940
Vehicle: 1992 hardbody
Thanks: 354
Thanked 128 Times in 118 Posts
Default Hard start 1992 hardbody ka24

I'm having a hard time starting my truck. I have added new cap and rotor and cleaned the injectors. What could be causing this issue? It does it all the time cold or hot.
__________________
What do you get from a nervous cow.... A milk-shake
Hardbody92 is offline   Reply With Quote
Old 05-06-2022, 08:44 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,819
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,109
Thanked 2,244 Times in 1,841 Posts
Default

What’s the timing set to? Should be 10 btdc
__________________
alabama_lowlife is online now   Reply With Quote
Thanked by:
Hardbody92 (05-07-2022)
Old 05-06-2022, 09:16 PM   #3
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,719
Vehicle: 96 HB
Thanks: 218
Thanked 922 Times in 803 Posts
Default

Hard time how? slow crank, long crank, not catching the spark?
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Old 05-07-2022, 03:24 AM   #4
Hardbody92
 
Hardbody92's Avatar
 
Join Date: Jan 2013
Location: South West Florida
Posts: 940
Vehicle: 1992 hardbody
Thanks: 354
Thanked 128 Times in 118 Posts
Red face

Quote:
Originally Posted by dvdswan View Post
Hard time how? slow crank, long crank, not catching the spark?
It's a long crank situation. I'm thinking its timing/spark related. I hope it ain't compression
__________________
What do you get from a nervous cow.... A milk-shake
Hardbody92 is offline   Reply With Quote
Old 05-07-2022, 01:03 PM   #5
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,195
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,838
Thanked 1,809 Times in 1,578 Posts
Default

Was it hard to start before the new parts or after?

If after, check the new parts. You may have a plug wire not seated or 2 wires swapped wrong.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
Hardbody92 (05-07-2022)
Old 05-07-2022, 02:18 PM   #6
rbourgeo
 
rbourgeo's Avatar
 
Join Date: Mar 2020
Location: British Columbia, Canada
Posts: 171
Vehicle: 1996 D21
Thanks: 55
Thanked 37 Times in 27 Posts
Default

Clogged fuel filter? Bad fuel pump? Bad fuel pressure regulator? Bad TPS?
rbourgeo is offline   Reply With Quote
Old 05-07-2022, 07:59 PM   #7
Hardbody92
 
Hardbody92's Avatar
 
Join Date: Jan 2013
Location: South West Florida
Posts: 940
Vehicle: 1992 hardbody
Thanks: 354
Thanked 128 Times in 118 Posts
Default

Quote:
Originally Posted by jp2code View Post
Was it hard to start before the new parts or after?

If after, check the new parts. You may have a plug wire not seated or 2 wires swapped wrong.
The motor came from my other 92 4wd. It started fine before but I cleaned up the motor and replaced a bunch of shit on it and took all the emissions crap off. I did clean my injectors using 12 volts from a battery, I think that was a bad idea.
__________________
What do you get from a nervous cow.... A milk-shake
Hardbody92 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:30 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.