Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-03-2022, 05:45 AM   #1
DatCamaroGuy
'91 D21 V6 4wd 5spd
 
Join Date: May 2022
Location: Marshfield, WI
Posts: 5
Vehicle: 1991 Nissan D21
Thanks: 0
Thanked 1 Time in 1 Post
Default Lost instrument/gauge cluster lights, tail lights, and marker lights.

(1991 model) Headlights, turn signals and brake lights work. Yesterday I went on a 4 hour round trip to pick up some parts and used a small trailer to transport them home, which is a standard 4 pin connection. I noticed that my end was corroded a little as this is the first time trailering with my pickup since I got it 6 months ago. I cleaned it and the tail lights on the trailer looked better than when I first saw them. I probably didn't clean the connector out enough, though.

As the cluster, marker, and tail lights all turned on when I turn the lights switch on the "markers only" spot on the light knob, I think it may be the switch. Funny enough, I bought one a few months ago because I thought it was the problem to a headlight out, but it wasn't, so I have the entire light switch/turn signal/cruise stick on hand. But if it was a fuse or a relay, where would it be located?

EDIT: I changed the tense of "turn" to "turned" to clarify that i have no cluster, marker, or tail lights at all.

Last edited by DatCamaroGuy; 05-03-2022 at 02:43 PM.
DatCamaroGuy is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:01 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.