Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 04-10-2021, 11:38 PM   #1
ChadM_87-d21
 
Join Date: Apr 2021
Location: TX
Posts: 9
Vehicle: Nissan d21 2.4l 1986
Thanks: 1
Thanked 0 Times in 0 Posts
Default Please help with 87 2.4l

I just bought a 87 d21 2.4l RWD. When I got it he told me that it jumps when driving. More like it bogs down on the top end. So I get home order new distributor w/ rotor, fuel filter, spark plugs, air filter. So I got all of that on, went to go crank it...nothing, like the battery was dead. So I knew I had put the spark plug wires on wrong. Now that I got them where they are supposed to be, it won't turn over. It backfires sometimes, and sometimes it doesn't. It almost sounds like the timing is off somehow with the noise that it makes.

Any professional comments welcome, thank you!
ChadM_87-d21 is offline   Reply With Quote
Old 04-10-2021, 11:55 PM   #2
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State
Posts: 520
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 534
Thanked 130 Times in 113 Posts
Default

Welcome Chad...

OK, have you pulled the codes yet? Under the passenger seat, is the ECU. Search the site on how to retrieve the codes... I'm sure someone will chime up...
__________________
Quote:
Originally Posted by Deerhurst
What he is saying it the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 04-11-2021, 01:11 AM   #3
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,426
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 987
Thanked 2,088 Times in 1,714 Posts
Default

Sounds like the distributor could be installed wrong. Have you tried rotating it to see if you can get it to start? You’ll need a timing light to set the timing once you get it to run.
__________________
alabama_lowlife is offline   Reply With Quote
Old 04-14-2021, 10:04 AM   #4
XoXSciFiGuy
 
XoXSciFiGuy's Avatar
 
Join Date: May 2017
Location: Auburn, WA
Posts: 3,060
Vehicle: 1997 D21 King Cab XE 2WD, 1998 Pathfinder.
Thanks: 197
Thanked 571 Times in 518 Posts
Default

Quote:
Originally Posted by ChadM_87-d21 View Post
I just bought a 87 d21 2.4l RWD. When I got it he told me that it jumps when driving. More like it bogs down on the top end. So I get home order new distributor w/ rotor, fuel filter, spark plugs, air filter. So I got all of that on, went to go crank it...nothing, like the battery was dead. So I knew I had put the spark plug wires on wrong. Now that I got them where they are supposed to be, it won't turn over. It backfires sometimes, and sometimes it doesn't. It almost sounds like the timing is off somehow with the noise that it makes.

Any professional comments welcome, thank you!
Distributor installed incorrectly I would think. Pull distributor back out, use a big wrench on the crankshaft bolt to bring the engine to top dead center on the compression stroke, and re-install distributor. You could be 180 degrees out. Was the engine turned over or the truck allowed to roll or move after you pulled the old distributor?
__________________

1997 King Cab XE, 5-sp, canopy, AC/PS, KA24E, 129,000 miles. Need a technical manual? Drop me a message. Chilton's for amateurs.
XoXSciFiGuy is offline   Reply With Quote
Old 04-21-2021, 01:01 AM   #5
ChadM_87-d21
 
Join Date: Apr 2021
Location: TX
Posts: 9
Vehicle: Nissan d21 2.4l 1986
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I got it figured out guys, I appreciate the input!
ChadM_87-d21 is offline   Reply With Quote
Old 04-21-2021, 01:07 AM   #6
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,445
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 893
Thanked 922 Times in 840 Posts
Default

What was it? Always good to update with the solution so when one of us has the same problem we can find a solution with a search.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 04-21-2021, 01:08 AM   #7
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 51
Posts: 10,487
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,675
Thanked 1,521 Times in 1,335 Posts
Default

Quote:
Originally Posted by ChadM_87-d21 View Post
I got it figured out guys, I appreciate the input!
What was the problem?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 04-21-2021, 07:06 PM   #8
ChadM_87-d21
 
Join Date: Apr 2021
Location: TX
Posts: 9
Vehicle: Nissan d21 2.4l 1986
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok so the motor is running alot better, but instead of it bogging down at 55-60 its doing it at 65-66. Any suggestions?
ChadM_87-d21 is offline   Reply With Quote
Old 04-21-2021, 07:08 PM   #9
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,426
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 987
Thanked 2,088 Times in 1,714 Posts
Default

Have you set the timing with a timing light?
__________________
alabama_lowlife is offline   Reply With Quote
Old 04-21-2021, 07:31 PM   #10
ChadM_87-d21
 
Join Date: Apr 2021
Location: TX
Posts: 9
Vehicle: Nissan d21 2.4l 1986
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No I haven't. Don't have one. Do I need to maybe play with my distributor a bit?
ChadM_87-d21 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.