Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 04-08-2021, 09:50 PM   #1
chrismtb
 
chrismtb's Avatar
 
Join Date: Jul 2016
Location: San Diego
Posts: 11
Vehicle: 1988 D21 4x4 SEV6
Thanks: 0
Thanked 4 Times in 2 Posts
Default Help identifying mystery wiring harnesses

There are these two wiring harness connectors sitting in my dash to the left of the steering column and I don't see anything obvious they would plug into. Does anyone recognize them and know where they are supposed to connect?

Photo:


Last edited by jp2code; 04-09-2021 at 06:27 PM.
chrismtb is offline   Reply With Quote
Old 04-08-2021, 10:04 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,430
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 988
Thanked 2,089 Times in 1,715 Posts
Default

What color are the wires?
__________________
alabama_lowlife is offline   Reply With Quote
Old 04-08-2021, 10:09 PM   #3
chrismtb
 
chrismtb's Avatar
 
Join Date: Jul 2016
Location: San Diego
Posts: 11
Vehicle: 1988 D21 4x4 SEV6
Thanks: 0
Thanked 4 Times in 2 Posts
Default

The 6-pin connector only has 3 pins filled:
White with black stripe
White with red bars
Yellow with black stripe

The 4-pin connector has all 4 filled:
Pink with red bars
Orange with red bars
Pink with blue stripe and red bars
Orange with blue stripe and red bars

By stripe I mean spanning the length of the wire, by bars I mean bars across the wire.

This is a 1988 D21 4x4 SEV6.

Last edited by chrismtb; 04-08-2021 at 10:37 PM.
chrismtb is offline   Reply With Quote
Old 04-09-2021, 02:27 AM   #4
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,430
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 988
Thanked 2,089 Times in 1,715 Posts
Default

Man, I’ve looked for a while and can’t find anything. I’ve been looking in the 89 manual because the 88-89 are pretty much the same as far as I know. As to which items the connectors go to, I can’t say. I’ve got an 86.5 manual I’ll look at tomorrow.
__________________
alabama_lowlife is offline   Reply With Quote
Old 04-09-2021, 03:43 AM   #5
street_rulerr
 
Join Date: Nov 2015
Location: West Coast
Posts: 2,360
Vehicle: 1996 4x4 5spd
Thanks: 0
Thanked 212 Times in 199 Posts
Default

what transmission do you have? could be provisions for something like cruise or "econ" mode for the trans. isnt there a clutch interlock disable on some trucks to bump the truck using the starter?
street_rulerr is offline   Reply With Quote
Old 04-09-2021, 04:02 AM   #6
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 49
Posts: 10,322
Vehicle: 87 VG33 Pathfinder SE 4x4 & 87 D21 SE
Thanks: 431
Thanked 1,307 Times in 1,188 Posts
Default

One would probably be for optional fog lights. The other could be for power mirrors or something.
cadillacdude1975 is offline   Reply With Quote
Old 04-09-2021, 04:22 AM   #7
chrismtb
 
chrismtb's Avatar
 
Join Date: Jul 2016
Location: San Diego
Posts: 11
Vehicle: 1988 D21 4x4 SEV6
Thanks: 0
Thanked 4 Times in 2 Posts
Default

It's a manual transmission.
It has the clutch interlock, which works fine. I use that in the driveway all the time to start it without climbing in to push the clutch when I'm 100% sure it's not in gear.
Were power mirrors and fog lights options in 1988? It definitely does not have either of those as the SEV6 model, but there are some covered slots in the dash for additional buttons that could have been for optional add-ons.
The dash backlights are not working and I was wondering if this could be related.
chrismtb is offline   Reply With Quote
Old 04-09-2021, 12:12 PM   #8
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,430
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 988
Thanked 2,089 Times in 1,715 Posts
Default

I can’t find anything on the Orange or Orange/blue wires. In later models Orange is one of the power wires to the hazard switch. It’s not listed in the 86.5 or 89 FSM except as for the automatic transmission stuff. None of the connectors for that are in the area.

Pink in other areas comes from the fuse box and is used as the power side for the illumination as well as the parking lamps before it goes through the switch. Pink/blue is the power for illumination and parking lights AFTER the headlight switch. The diagrams don’t show the 4 pin connector. Pink is also used between the ECM and a throttle switch that is under the hood.

Power mirrors were an option but those are not the wire colors for the mirrors.

Yellow/black is usually for the charge circuit for the alternator. It also goes to the bulb check relay. Neither of those would be with that 6 pin connector. White/black is often a power wire.

The 86.5 FSM mentions a seat heater for some models. There is a 4 pin connector near that area. No wiring colors were shown anywhere though.
__________________
alabama_lowlife is offline   Reply With Quote
Old 04-09-2021, 02:37 PM   #9
Reserector
the Flaming Marshmallow
 
Reserector's Avatar
 
Join Date: Oct 2015
Location: Laurel, MS
Posts: 1,721
Vehicle: Nissan HB KC 4x4
Thanks: 47
Thanked 443 Times in 347 Posts
Default

Buzzer?
Intermittent wipers?
Cruise control (only available with auto trans)?
Self-destruct module?


My manual trans truck with the XE package has those as well. I assumed it was for cruise control.
Reserector is offline   Reply With Quote
Old 04-09-2021, 03:04 PM   #10
chrismtb
 
chrismtb's Avatar
 
Join Date: Jul 2016
Location: San Diego
Posts: 11
Vehicle: 1988 D21 4x4 SEV6
Thanks: 0
Thanked 4 Times in 2 Posts
Default

Quote:
Originally Posted by Reserector View Post
Buzzer?
Intermittent wipers?
Cruise control (only available with auto trans)?
Self-destruct module?


My manual trans truck with the XE package has those as well. I assumed it was for cruise control.
You have both of those unused connectors as well? If that's the case, that alleviates my concern that they are supposed to be connected somewhere.
chrismtb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.