Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 05-23-2021, 10:40 PM   #11
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,348
Vehicle: 96 HB
Thanks: 182
Thanked 797 Times in 700 Posts
Default

Does it still have the original air cleaner housing? Check the IAT sensor wiring and connector.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Old 05-23-2021, 11:42 PM   #12
Rebellion32
 
Join Date: Mar 2021
Location: Indiana
Posts: 12
Vehicle: 1997 Nissan Pickup
Thanks: 0
Thanked 5 Times in 3 Posts
Default

Yes, it still has the original air filter housing. The IAT is plugged in and functional. I can see it responding on the live feed on my OBDII scanner.
Rebellion32 is offline   Reply With Quote
Old 05-24-2021, 03:55 AM   #13
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 55
Posts: 7,888
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 71
Thanked 997 Times in 910 Posts
Default

I used a Halloween smoke machine to find the vacuum leak on my former 93, I removed one end of the large hose coming off the brake booster, make sure if you do this to remove the hose from the correct side of the check valve or no smoke will go into the system. Also you have to put a rag in the throttle body or the smoke will come out.


Mine was leaking badly from the IACV gasket, as it fell when I reinstalled the IACV after cleaning it, truck ran so bad it would stall when coming to a stop. Bought a new OEM gasket and was good afterwards.



short video I made at the time:


https://youtu.be/eqPhEIh40Xc
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Thanked by:
Balkins (06-08-2021)
Old 05-24-2021, 04:21 PM   #14
street_rulerr
 
Join Date: Nov 2015
Location: West Coast
Posts: 2,394
Vehicle: 1996 4x4 5spd
Thanks: 0
Thanked 218 Times in 204 Posts
Default

^^ i think you posted that before and i thought you were a straight genius for doing that.
street_rulerr is offline   Reply With Quote
Old 05-24-2021, 08:55 PM   #15
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 55
Posts: 7,888
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 71
Thanked 997 Times in 910 Posts
Default

Thanks, I have posted it before, worked for me, we had the machine so I used it.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 06-03-2021, 05:03 PM   #16
PoodlePuncher
 
PoodlePuncher's Avatar
 
Join Date: Jan 2020
Location: Minnesota
Posts: 152
Vehicle: 95 XE
Thanks: 14
Thanked 19 Times in 18 Posts
Default

did you ever find a solution? my truck started having a similar issue.

after driving for a while, when i come to a stop, the engine revs up to about 2k, then falls on it's face. surging around 500rpm before dying, if i don't give it gas in time...

Some times it just dies if i have to slow down quickly... like for a signal on the highway (from around 55mph).


it always starts right back up, and for the life of me, i can't find any leaks.
think it has to be a sensor..
__________________
'95 4x4 King Cab XE - '16 Veloster Turbo - '00 Durango
YouTube

Last edited by PoodlePuncher; 06-03-2021 at 05:10 PM.
PoodlePuncher is offline   Reply With Quote
Old 06-07-2021, 11:52 AM   #17
etx97xe
 
Join Date: Apr 2016
Location: longview tx
Posts: 224
Vehicle: nissan pickup 97
Thanks: 1
Thanked 18 Times in 17 Posts
Default Ummm

Kinda sounds like a idle speed control going bad or choke?
etx97xe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.