Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 05-20-2021, 02:08 PM   #1
Sudsierstar9
 
Join Date: May 2021
Location: Connecticut
Posts: 3
Vehicle: 1990 d21
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Why won't my truck run right

This is my first post here
I just replaced the timing chain, oil pump, head gasket, and did an egr delete. I forgot to take the butterfly valve out of the intake before reassembly so I hooked a vacuum tube straight from that to the the throttle body. It only runs on the throttle and I've moved the distrubitur all over but it still wont run right. Does anyone have some advice on how to fix this?
Sudsierstar9 is offline   Reply With Quote
Old 05-20-2021, 02:28 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,496
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,012
Thanked 2,111 Times in 1,735 Posts
Default

You have the timing wrong. Set the #1 cylinder to TDC on the compression stroke and install the oil pump shaft correctly. This thread has pics of how it should go.
http://www.infamousnissan.com/forum/...ad.php?t=33948
__________________
alabama_lowlife is offline   Reply With Quote
Old 05-20-2021, 02:54 PM   #3
Sudsierstar9
 
Join Date: May 2021
Location: Connecticut
Posts: 3
Vehicle: 1990 d21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So it doesnt have anything to do with the butterfly valve? I took it apart again and the timing marks are all lined up on the chain/sprockets, and the distrubitur is pointing at the #1 mark I painted on before starting the teardown. I'm just trying to think of anything else that could be wrong
Sudsierstar9 is offline   Reply With Quote
Old 05-20-2021, 02:57 PM   #4
Sudsierstar9
 
Join Date: May 2021
Location: Connecticut
Posts: 3
Vehicle: 1990 d21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by alabama_lowlife View Post
You have the timing wrong. Set the #1 cylinder to TDC on the compression stroke and install the oil pump shaft correctly. This thread has pics of how it should go.
http://www.infamousnissan.com/forum/...ad.php?t=33948
So it doesnt have anything to do with the butterfly valve? I took it apart again and the timing marks are all lined up on the chain/sprockets, and the distrubitur is pointing at the #1 mark I painted on before starting the teardown. I'm just trying to think of anything else that could be wrong
Sudsierstar9 is offline   Reply With Quote
Old 05-20-2021, 03:47 PM   #5
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 41
Posts: 10,496
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,012
Thanked 2,111 Times in 1,735 Posts
Default

Which butterfly valve? Why do you need to remove it?
__________________
alabama_lowlife is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.