Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 07-29-2020, 11:46 PM   #1
alehasfriends
 
Join Date: Dec 2017
Location: Michigan
Posts: 5
Vehicle: 1989 Nissan D21 Automatic
Thanks: 12
Thanked 0 Times in 0 Posts
Default Buzzing noise when driving

The other day, a loud buzzing noise came from the passenger side and stopped when it downshifted. There was smoke from the engine. I checked my fluids and noticed the coolant was near empty even though i had just filled it up. I filled it and that seemed to fix the problem. There is a slight coolant leak and i had just driven it up to 5,000 feet and used the 4 wheel drive a few times.

Just now getting on the highway, the sound came back and didn't stop until I got off the highway and it downshifted. Now the engine sounds strained. No smoke this time and all the levels were fine--including the coolant.

It's a Nissan D21 1989 SE V6 Automatic. Thank you!
alehasfriends is offline   Reply With Quote
Old 07-30-2020, 12:02 AM   #2
alehasfriends
 
Join Date: Dec 2017
Location: Michigan
Posts: 5
Vehicle: 1989 Nissan D21 Automatic
Thanks: 12
Thanked 0 Times in 0 Posts
Default

Maybe it's the locking hub? The noises Did seem different. The loud chainsaw-like noise from the other day seemed to come from the inside toward the engine and this one just now was on the left hand side of the vehicle and was much louder near the barrier.

I just had work done to the shocks and the mechanic was saying how the hubs were really difficult.

The only thing that's stopping me from that conclusion is how the noises both times quit when it downshifted.

Last edited by alehasfriends; 07-30-2020 at 12:07 AM. Reason: Clarification
alehasfriends is offline   Reply With Quote
Old 07-30-2020, 12:05 AM   #3
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State
Posts: 80
Vehicle: 89' D21 KingCab SE V6 5spd 2WD - 87' D21 KingCab SE V6 5spd 2WD
Thanks: 102
Thanked 22 Times in 20 Posts
Default

Get the front off the ground and spin each tire. Breaks not releasing? Bearings? Might start here......
89'HBV6 is offline   Reply With Quote
Old 07-30-2020, 06:20 AM   #4
XoXSciFiGuy
 
XoXSciFiGuy's Avatar
 
Join Date: May 2017
Location: Auburn, WA
Posts: 2,909
Vehicle: 1997 D21 King Cab XE 2WD, 1998 Pathfinder.
Thanks: 185
Thanked 515 Times in 468 Posts
Default

Quote:
Originally Posted by 89'HBV6 View Post
Get the front off the ground and spin each tire. Breaks not releasing? Bearings? Might start here......
I second this idea. Don't drive it any more until you do. Whatever it is, something needs fixing for sure.
__________________

1997 King Cab XE, 5-sp, canopy, AC/PS, KA24E, 125,000 miles. Need a technical manual? Drop me a message. Chilton's for amateurs.
XoXSciFiGuy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:22 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.