Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 09-12-2020, 09:17 PM   #1
travisg96
 
Join Date: Sep 2020
Location: OR
Posts: 36
Vehicle: 1986 D21 Long Bed HD
Thanks: 1
Thanked 0 Times in 0 Posts
Default D21 No spark

I just picked up a 1986 D21 long bed HD with a VG30i. It was running when I got it but had an issue with the fuel pump and after fixing that the truck stopped running. It started and would run for a minute and then die, now it will not start. there is no spark to the coil wire. There is power to the coil when I turn the ignition on but am unsure of what the other pin is, is it a ground? Also have some unknown missing connections that a previous owner has connected with an alligator clip. These are two plugs on the passenger side just under the fusible links.I will add some pictures when I figure out how to get them onto photobucket.
travisg96 is offline   Reply With Quote
Old 09-12-2020, 10:46 PM   #2
travisg96
 
Join Date: Sep 2020
Location: OR
Posts: 36
Vehicle: 1986 D21 Long Bed HD
Thanks: 1
Thanked 0 Times in 0 Posts
Default

So here is what I have figured out, mounted to the back of the coil is the ignition module. there is 4 wires coming into it, Bw, Bp, Bl red spots, white. The Bw wire is hot when the key is on, The Bl red spot is hot when key is on, the Bp is ground and the white one seems to not have a signal. The coil side plug has two wires Bw and Bl, the Bw is hot when the key is on but I get no signal from Bl even when engine is turning over. So the Bl with red spot seems to connect to some sort of resistor if I read the symbol right and turns into a W red spot wire that runs into harness. The Bw wire runs into the harness but splices with a jumper that goes to a connector that has a capacitor symbol and then turns into a B red spot wire that runs to the distributor and connects to a terminal that is ground.
travisg96 is offline   Reply With Quote
Old 09-12-2020, 11:17 PM   #3
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 6,932
Vehicle: 1986.5 Hardbody
Thanks: 870
Thanked 792 Times in 723 Posts
Default

Ditch photobucket. Most of us recommend imgur.



Where in OR are you? If you are fairly close I may be able to give you a hand. We have SBJ up north.



Is it no spark on all cylinders? Do you have a copy of the FSM?
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 09-12-2020, 11:58 PM   #4
travisg96
 
Join Date: Sep 2020
Location: OR
Posts: 36
Vehicle: 1986 D21 Long Bed HD
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I am in Junction City. There is no spark to anything. no spark at coil. What is FSM? Ahh Factory service manual. I have one downloaded for a 1989 but I am not sure if it is the same as 1986.

Last edited by travisg96; 09-13-2020 at 12:02 AM. Reason: Adding question
travisg96 is offline   Reply With Quote
Old 09-13-2020, 12:39 AM   #5
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 6,932
Vehicle: 1986.5 Hardbody
Thanks: 870
Thanked 792 Times in 723 Posts
Default

Small world! I was just up in Eugene this morning. I'm from the Roseburg area.



Use the closest year FSM you can find. 89 is probably it. There are some differences in the 86.5 vs everything later but mostly it's in the control systems. ECU and some minor wiring differences.



I believe the ECM tells the coil what to do. I'd have to consult the FSM on how to check that.



The ECM on the 86.5 will modify ignition timing as it seems necessary. Wonder if the coil isn't seeing a signal or is ignoring a signal.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 09-13-2020, 01:43 AM   #6
travisg96
 
Join Date: Sep 2020
Location: OR
Posts: 36
Vehicle: 1986 D21 Long Bed HD
Thanks: 1
Thanked 0 Times in 0 Posts
Default

It looks like you have the same year as mine so maybe they are similar. So what kind of signal should I be getting. I unplugged the ICM from the coil and got hot on the Bw wire but nothing on the blue wire. I know the blue with red spot wire is hot when the key is on I unplugged the connector where the wire changes and checked there and it was hot. Like I said I think that connector is a resistor based on the resistor code stamped on it, it was labeled 2.2 ohm. Am still trying to figure out imgur so I can post pictures and not just rely on descriptions.
travisg96 is offline   Reply With Quote
Old 09-13-2020, 02:08 AM   #7
travisg96
 
Join Date: Sep 2020
Location: OR
Posts: 36
Vehicle: 1986 D21 Long Bed HD
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ok so here is pictures of what I am talking about the colors being



This is the conector that jumbers the Bl red spot wire and the w red spot wire.



This is the connector that connects the BL/w wire to a BL red spot wire that runs to dist ground.

https://imgur.com/xieeChM

Last edited by travisg96; 09-13-2020 at 02:47 AM.
travisg96 is offline   Reply With Quote
Old 09-13-2020, 02:16 AM   #8
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 6,932
Vehicle: 1986.5 Hardbody
Thanks: 870
Thanked 792 Times in 723 Posts
Default

That's a capacitor. 2.2 microfarad cap. You should measure contanuity through the cap. If it's open it's been. I believe some multimeters have a setting to measure caps.



Honestly, I'd have to look at the FSM to diagnose further. I've never had any electrical issues with my truck.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 09-13-2020, 02:19 AM   #9
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 6,932
Vehicle: 1986.5 Hardbody
Thanks: 870
Thanked 792 Times in 723 Posts
Default

Any codes present?
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Thanked by:
travisg96 (09-13-2020)
Old 09-13-2020, 02:27 AM   #10
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 51
Posts: 10,015
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,593
Thanked 1,370 Times in 1,206 Posts
Default

There is a link in my signature below to a thread on checking the codes. Deerhurst contributed one of the videos, and its ECU will be identical to yours.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is online now   Reply With Quote
Thanked by:
Deerhurst (09-13-2020)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.