Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 06-26-2014, 03:54 AM   #1
pixelss
 
Join Date: May 2014
Location: orlando
Posts: 79
Vehicle: hardbody - 1995
Thanks: 3
Thanked 0 Times in 0 Posts
Angry fuel pump?

Guys,


So i bought 95 with about 175k miles, the truck had very rough idling from the get go, bought a idle air control valve, MAF sensor, plugs and plus wires are new, fuel filter too. still had rough idling and coming back from the gas station today i felt the truck losing a lot of power and worse idling than ever.

today i turn on the truck and ran for 3 -5 minutes and stalled. then it didn't want it to turn on. sprayed some carb cleaner and the truck ran for about 30 seconds. Is that a giving that fuel pump is failing?

if so, best way is removing the bed right? ( 3 bolts? ) and get to the fuel pump that way?

pixelss is offline   Reply With Quote
Old 06-26-2014, 06:32 AM   #2
Nissanator
Low n Slow
 
Nissanator's Avatar
 
Join Date: Apr 2012
Location: Calgary, Ab Canada
Posts: 222
Vehicle: 89 hardbody base s13 ka25de swap fully built and boosted . in the works
Thanks: 37
Thanked 20 Times in 19 Posts
Default

Im not sure if it would be the fuel pump or not but the easiest way to access the fuel pump is to drop the tank mine was 6 or 8 bolts and a few hoses. Just make sure you have a friend and a jack.
__________________
1989 Single cab- Daily Drifter half show half go. Build thread->http://www.infamousnissan.com/forum/...ad.php?t=26966
2000 frontier crew cab 4x4 mt- Daily
1995 extended cab 4x4 mt 6 inch lift on 35's-sold
1997 mistubishi eclipse gsx fully built -crank walked and parted out
2001 Subaru Forester S- sold
1993 extended cab-Sold to a good friend
Nissanator is offline   Reply With Quote
Old 06-26-2014, 08:41 AM   #3
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 54
Posts: 7,678
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 66
Thanked 939 Times in 860 Posts
Default

Can you hear if the fuel pump is priming when you first turn the key on? If not have someone lay under the truck and listen for it.

Check to see if the vacuum line is on the fuel pressure regulator also.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 06-26-2014, 11:29 AM   #4
Fanophins
 
Join Date: Feb 2012
Location: Lake Worth Florida
Posts: 982
Vehicle: 95 Nissan Hardbody SE 4x4 king cab
Thanks: 158
Thanked 79 Times in 61 Posts
Default

Pull your codes from your ECM I'm guessing O2 sensor.
__________________
Originally Posted by cadillacdude1975 View Post
if you can wipe your ass, chew gum and send a text message at the same time, you can repair one of these hardbody AC systems.
Fanophins is offline   Reply With Quote
Old 06-26-2014, 12:10 PM   #5
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 51
Posts: 9,993
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,591
Thanked 1,364 Times in 1,201 Posts
Default

Quote:
Originally Posted by Fanophins View Post
Pull your codes from your ECM I'm guessing O2 sensor.
+1

Do not try to chase how the ECM is making the engine "act" when it has stored codes.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is online now   Reply With Quote
Old 06-26-2014, 12:21 PM   #6
Tally HB
The Old Guy
 
Join Date: Feb 2013
Location: North Florida
Age: 57
Posts: 721
Vehicle: 1989 D21 Base 2WD 2.4L
Thanks: 23
Thanked 100 Times in 80 Posts
Default

Have you ever changed the fuel filter?
__________________
1989 D21 Standard Cab 4x2
2.4L Z24i, 5spd
Tally HB is offline   Reply With Quote
Old 06-26-2014, 01:06 PM   #7
pixelss
 
Join Date: May 2014
Location: orlando
Posts: 79
Vehicle: hardbody - 1995
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jp2code View Post
+1

Do not try to chase how the ECM is making the engine "act" when it has stored codes.
that's the funny part. No codes.

ahardb0dy: all i can hear is a click. but if put some carb cleaner the truck does turn on.
pixelss is offline   Reply With Quote
Old 06-26-2014, 02:27 PM   #8
YEPEE
 
Join Date: Mar 2013
Location: Phoenix
Posts: 1,773
Vehicle: 86.5 HB,95 HB, 02 Sentra Spec-V
Thanks: 228
Thanked 294 Times in 254 Posts
Default

if it comes down to it, should be 4 bed bolts & 2 for the fuel filler and of course unplug the t/lmps... but I am going off memory
YEPEE is offline   Reply With Quote
Old 06-26-2014, 03:00 PM   #9
Fanophins
 
Join Date: Feb 2012
Location: Lake Worth Florida
Posts: 982
Vehicle: 95 Nissan Hardbody SE 4x4 king cab
Thanks: 158
Thanked 79 Times in 61 Posts
Default

Quote:
Originally Posted by pixelss View Post
that's the funny part. No codes.

ahardb0dy: all i can hear is a click. but if put some carb cleaner the truck does turn on.
Where is the click coming from? Could be a relay.
__________________
Originally Posted by cadillacdude1975 View Post
if you can wipe your ass, chew gum and send a text message at the same time, you can repair one of these hardbody AC systems.
Fanophins is offline   Reply With Quote
Old 06-26-2014, 03:03 PM   #10
pixelss
 
Join Date: May 2014
Location: orlando
Posts: 79
Vehicle: hardbody - 1995
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by YEPEE View Post
if it comes down to it, should be 4 bed bolts & 2 for the fuel filler and of course unplug the t/lmps... but I am going off memory
so the pump is priming and relay is clinking, i was able to turn on the truck today, but no power( i step in the gas a just move slowly ) and rough rough idle ( almost stalling ) No codes** will install a new O2 sensor =/ is backfiring too.

What else can i check?

Bad plugs?


Last edited by pixelss; 06-26-2014 at 10:51 PM.
pixelss is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:38 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.