Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 07-04-2014, 11:27 PM   #1
tn backwoods
 
Join Date: Jun 2014
Location: tn
Posts: 38
Vehicle: 1995 d21
Thanks: 5
Thanked 0 Times in 0 Posts
Default well lifters still tickin

well i havent seem to be able to fix my lifter tick on the driverside since buying the truck. i put a bottle of rislone in the oil when i got it and changed it. then added half a can of seaofoam to new oil. no luck with those. a friend of mine told me bout another guy he works with at the factory we both know to help me. i knew he'd been to the diesel college in nashville but he just told me last night the guy worked at the nissan dealer for several years. he has a 4 cyl hardbody. so he came by today and said it was the lifters and pointed out a little miss at very low throttle because of the lifter. he said do the tranny fluid in the crank but not to drive it. he said thats what nissan had them do and charged the hell out of ppl and said it worked 95% of the time. well i tried it after he left and let it run for 15 min and changed the oil and still no luck. he said he would come over and we'd all tackle the timing belt and water pump so maybe he'll help change the lifters out too. just an update on my new to me nissan
__________________
1995 XE hardbody. V6, 5 speed, 4x4, excab.
tn backwoods is offline   Reply With Quote
Old 07-04-2014, 11:36 PM   #2
tn backwoods
 
Join Date: Jun 2014
Location: tn
Posts: 38
Vehicle: 1995 d21
Thanks: 5
Thanked 0 Times in 0 Posts
Default

oh and me and my buddy were checkin out puttin an oil pressure gauge on my truck and found the oil sending unit there by the oil filter...well there was nothing plugged in to it...so we got to lookin more and found a wire that was coming out of a wire tube and was hanging cut. he looked it up and it was a yellow wire and the oil sending unit was yellow. so that made me nervous and we spliced it up and put a female end and plugged it up. turn the key on and then i had the oil can light light up like it should. unplugged everything to make sure it was the right wire and the light went out. so i got that hooked back up and the light goes off at engine start and didnt come on the whole way home so maybe all is good there!
__________________
1995 XE hardbody. V6, 5 speed, 4x4, excab.
tn backwoods is offline   Reply With Quote
Old 07-05-2014, 12:56 AM   #3
Foul_Mouth
Pounding Rox Truck
 
Join Date: Mar 2010
Location: Western NY
Posts: 4,649
Vehicle: 1986.5 4WD Reg Cab/ 1991 2WD Reg Cab(Red)/ 1995 2WD Reg Cab(Green)/ 92 WD21 4WD PathFinder
Thanks: 536
Thanked 802 Times in 640 Posts
Default

Check your injectors, they are known to make a loud ticking noise that can sound like lifter noises.
__________________
Nissan Truck Videos (Builds-Racing-Shows-Tech)
https://www.youtube.com/c/NissanTruckguy
IG@ rainmaker_d21








Foul_Mouth is offline   Reply With Quote
Old 07-05-2014, 05:10 AM   #4
tn backwoods
 
Join Date: Jun 2014
Location: tn
Posts: 38
Vehicle: 1995 d21
Thanks: 5
Thanked 0 Times in 0 Posts
Default

hmm havent heard anything bout them yet. 2 mech have said lifters though thats all i know... it ticks slowly at an idle and speeds up with throttle. i know the time i hear it the most is when your driving down the road and you have to just barely barely have the pedal pushed down to keep speed...that when it just ticks away, if your driving and just hammer down on it it seems like its not as loud. how do you check injectors? sorry im not the best mech but get by
__________________
1995 XE hardbody. V6, 5 speed, 4x4, excab.
tn backwoods is offline   Reply With Quote
Old 07-05-2014, 07:30 AM   #5
Tally HB
The Old Guy
 
Join Date: Feb 2013
Location: North Florida
Age: 57
Posts: 721
Vehicle: 1989 D21 Base 2WD 2.4L
Thanks: 23
Thanked 100 Times in 80 Posts
Default

Quote:
Originally Posted by tn backwoods View Post
hmm havent heard anything bout them yet. 2 mech have said lifters though thats all i know... it ticks slowly at an idle and speeds up with throttle. i know the time i hear it the most is when your driving down the road and you have to just barely barely have the pedal pushed down to keep speed...that when it just ticks away, if your driving and just hammer down on it it seems like its not as loud. how do you check injectors? sorry im not the best mech but get by
Take a long thin stick, dowel rod or long screwdriver and place the largest end, or handle of the screwdriver, against your ear and then put the tip against each injector plug. Works as good as a stethoscope. If its an injector clicking it will be very detectable. Do this same thing but put the tip against the valve cover and see if the noise is louder than the injectors.
__________________
1989 D21 Standard Cab 4x2
2.4L Z24i, 5spd
Tally HB is offline   Reply With Quote
Old 07-05-2014, 07:32 AM   #6
Tally HB
The Old Guy
 
Join Date: Feb 2013
Location: North Florida
Age: 57
Posts: 721
Vehicle: 1989 D21 Base 2WD 2.4L
Thanks: 23
Thanked 100 Times in 80 Posts
Default

If you decide it is lifters then you can drain a couple quarts of oil, replace those quarts with straight diesel fuel and run the engine at idle for 15 to 20 minutes. Then do a normal oil change with filter. See if it cleans any sludge from the lifters.

Sometimes they just won't come back and pump up and they have to be replaced.
__________________
1989 D21 Standard Cab 4x2
2.4L Z24i, 5spd
Tally HB is offline   Reply With Quote
Old 07-05-2014, 05:00 PM   #7
87kingcab
Canada EH?
 
87kingcab's Avatar
 
Join Date: May 2014
Location: Alberta Canada
Posts: 709
Vehicle: 1987 Nissan D21 Hardbody Kingcab SE V6 4X4
Thanks: 44
Thanked 100 Times in 76 Posts
Default

Are you sure there isn't a small hole in the exhaust manifold? I have a small leak and it sounds exactly like a lifter tick when I'm driving.
__________________
1987 Kingcab SE-V6 4x4 5 speed D21
87kingcab is offline   Reply With Quote
Thanked by:
Tally HB (07-05-2014)
Old 07-05-2014, 05:48 PM   #8
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 48
Posts: 10,023
Vehicle: 87 D21 SE KC V6 2wd 5sp & 87 Pathfinder 4x4 SE
Thanks: 399
Thanked 1,216 Times in 1,118 Posts
Default

those manifolds are notorious for cracking. and the bolts are notorious for breaking. broken bolt = possible blown exhaust manifold gasket = ticking sound.
cadillacdude1975 is offline   Reply With Quote
Old 07-06-2014, 03:43 AM   #9
tn backwoods
 
Join Date: Jun 2014
Location: tn
Posts: 38
Vehicle: 1995 d21
Thanks: 5
Thanked 0 Times in 0 Posts
Default

yeah ya'll have told me all about the exhaust manifold bolts being junk and breaking. i guess i need to take the heat shield off and look. the mechanic that looked at it before i bought it and the guy that worked at nissan for years both said it was the lifters though. i know it doesnt quiet down any when the engine is hot like ya'll said alot of the time it will do if its the exhaust when the metal expands. what exactly are you lookin for when to take the heat shields off? is it something very obvious?
__________________
1995 XE hardbody. V6, 5 speed, 4x4, excab.
tn backwoods is offline   Reply With Quote
Old 07-06-2014, 03:47 AM   #10
tn backwoods
 
Join Date: Jun 2014
Location: tn
Posts: 38
Vehicle: 1995 d21
Thanks: 5
Thanked 0 Times in 0 Posts
Default

and the guy that worked at nissan did have me put my hand on the intake and he barely pushed on the throttle and pointed out a very small miss that he said was cuz of the lifter
__________________
1995 XE hardbody. V6, 5 speed, 4x4, excab.
tn backwoods is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.