Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 01-04-2021, 11:25 PM   #1
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default Surging and backfiring on 92 nissan hardbody 2.4

I have a 92 hardbody 2.4 and it surges and bucks on cold start. Sometimes it smoothens out but act like its starving for fuel and it will backfire. If i ease on the throttle once smooth it drives ok but if i floor it, it will sputter and almost sounds like a turbo 2 step. Its my daily and i start back to work soon so any help would be appreciated. Ive changed spark plugs, distributor, checked for bad grounds and loose connections. Aldo the relays under the hood keep clicking while its surging.
Dilla is offline   Reply With Quote
Old 01-04-2021, 11:49 PM   #2
nunya
Banned
 
Join Date: Apr 2019
Location: Southeast
Posts: 975
Vehicle: nissan d21 93 kingcab 2wd
Thanks: 289
Thanked 218 Times in 181 Posts
Default

Quote:
Originally Posted by Dilla View Post
I have a 92 hardbody 2.4 and it surges and bucks on cold start. Sometimes it smoothens out but act like its starving for fuel and it will backfire. If i ease on the throttle once smooth it drives ok but if i floor it, it will sputter and almost sounds like a turbo 2 step. Its my daily and i start back to work soon so any help would be appreciated. Ive changed spark plugs, distributor, checked for bad grounds and loose connections. Aldo the relays under the hood keep clicking while its surging.
How does it act after warmed up?
nunya is offline   Reply With Quote
Old 01-05-2021, 02:51 AM   #3
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

It only smoothens out sometimes. Mostly it stays bucking and jerking. No smooth idle. The rpm needle bounces and it acts like its going to die but then surges back and forth. But of it does smooth out then it idles fine bit if i punch the throttle, it stutters and sounds like its starved for fuel. It has new injectors on it and all the fuel system is new.
Dilla is offline   Reply With Quote
Old 01-05-2021, 03:46 AM   #4
PorknBeans
 
Join Date: Dec 2019
Location: Where I can see the air I breathe...
Posts: 203
Vehicle: Original owner of my 3-pdl 1997 Nissan Hardbody King Cab XE 2WD 5-spd.
Thanks: 22
Thanked 62 Times in 48 Posts
Default

Any trouble codes showing on the ECM? Check the timing with a timing light and set to 10* BTDC. Download the factory service manual and read through the basic procedures to set up components correctly. Look into trouble codes and start troubleshooting.

I think the ECM is under the passenger seat. You might have to remove that seat to access the ECM to read the codes. This is where the ECM was located on my '89 D21.

What regular maintenance has been done on the truck?
__________________

Last edited by PorknBeans; 01-05-2021 at 06:29 AM.
PorknBeans is offline   Reply With Quote
Old 01-05-2021, 04:44 AM   #5
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,244
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 885
Thanked 865 Times in 791 Posts
Default

Turbo noise/whistle? Gotta be a huge vacuum leak.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 01-05-2021, 04:39 PM   #6
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

Im taking off valve covers today to check timing chain and also gonna check the throttle body gadkets as well. Ive changed all vacuum lines and checked egr valve so im just hoing through elimination process
Dilla is offline   Reply With Quote
Old 01-05-2021, 04:41 PM   #7
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

And i havent checked for any codes but ill do that as well today
Dilla is offline   Reply With Quote
Old 01-06-2021, 05:56 AM   #8
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

Timing is good and didnt get to check codes today but im also gonna check throttle body gaskets and do a smoke test for vacuum leaks
Dilla is offline   Reply With Quote
Old 01-07-2021, 10:34 PM   #9
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

I tried to check codes today and the ecu wont enter diagnostic mode. The green and red leds blink togegher then the red led light stays and. I rotate the slot clockwise and nothing. Sat there for over a minute waiting. Is the ecm bad?
Dilla is offline   Reply With Quote
Old 01-07-2021, 10:58 PM   #10
Dilla
 
Join Date: Jan 2021
Location: LA
Posts: 9
Vehicle: 1992 hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

Fixed it . It was a bad ecm. I luckily have 2 hardbodys and took the ecm out of the parts truck and swapped it and boom. Runs like a champ��������
Dilla is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:34 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.