View Single Post
Old 08-24-2020, 12:20 AM   #3
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: OR
Posts: 2,839
Vehicle: '90 D21 4cyl 5spd 2wd
Thanks: 315
Thanked 491 Times in 435 Posts
Default

Sorry, I just saw this thread. It is easy enough to crawl under there and adjust the switch position if you need. JP, do you have a code reader that does live data? Some of them will tell you what position the switch is in, so you could put it in reverse and see if it changes from park to reverse on the scanner at the same time. On of my scan tools does it, although it only differentiates between neutral and drive...neutral is for park and neutral and drive is for everything else. Still, you'd be able to see it change when you go from park to reverse. I would bet it's probably just out of adjustment and that's why the reverse lights don't come on. You could always turn the key on and see if the lights come on in park or neutral instead. BTW, I did this same job on a 2000 or 2001 Xterra a few years back. That wiring harness is a real fucker to get in and out of there. I had to use a piece of string to fish it through and make sure it was routed correctly.

I'd probably consult the wiring diagrams and go after the connectors first, since they are up front by the battery. Figure out which pins are supposed to be be open/closed in each gear and go from there. A basic multimeter is all that's needed to test it. I don't believe there's any sort of relay in between the switch and the backup lights, but don't quote me on that.
SBJ is offline   Reply With Quote
Thanked by:
jp2code (08-24-2020)