Infamous Nissan - Hardbody / Frontier Forums

Infamous Nissan - Hardbody / Frontier Forums (http://www.infamousnissan.com/forum/index.php)
-   Wiring and Electrical (http://www.infamousnissan.com/forum/forumdisplay.php?f=47)
-   -   86 Nissan d21 fires right up, then dies (http://www.infamousnissan.com/forum/showthread.php?t=32570)

TommyB50 09-20-2014 05:46 AM

86 Nissan d21 fires right up, then dies
 
Here's where I'm at...
86 Nissan d21 HB vg30
Changed the spark plugs and wires..truck drove great after went to return a wrong part bcz I had an idle issue that was a vacuum problem disconnected..on my way home stopped and put some premium (93 octane) gas in and that's where things went left...after this I noticed intermittent misses, pulled all the spark plugs and checked the gap (.44 right?)..double and tripled checked all my plug wires to make sure they we're all on correct and that none of them we're touching each other, still had the misfire decided to call it last night cause it was late, woke up this morning and now it will start right up, sometimes will idle for less than 1 min then dies, will stay running if I can get my foot on the gas.
Was really frustrated and don't have the resources to pull and swap parts as this is my only vehicle.. Some things to note: ngk copper plugs , 155k miles, and put a bottle of Lucas injector cleaner in.


Possibly..EGR ? TPS? Alittle lost on this one, truck is currently at the shop and they have been messing with it for a few days... Still nothing
Tried looking for a similiar problem in other threads nothing really quite matched..

Also the shop mentioned that it would run for 30 minutes or so perfectly then they would shut it off and turn it back on and it would run like shit again, pretty much when it gets to running temp is when the problems start..


Any input is welcome, thanks tom
Posted on Nico and 150 views with no response...

alabama_lowlife 09-20-2014 12:20 PM

If it's doing this once it warms up, it could be a coolant temp sensor problem. It's located near the front of the engine. It's not the one with a single wire, that is for the gauge. This one has 2 wires I believe.

Also, are you sure you didn't get some bad gas? Sounds like maybe it had some water in it. Maybe look at the fuel filter to see if it has trash or water in it.

cadillacdude1975 09-20-2014 03:45 PM

have you checked the computer for codes?

TommyB50 09-20-2014 05:06 PM

Going to pull codes today hopefully...

Was thinking the same thing about bad gas as well, just seems highly unlikely but I know it does happen...

Coolant temp sensor seems to make sense, possible for it to cause a misfire half the time?

What do yu guys think ab TPS or EGR? Is that just not in the cards?

Question ab codes...never done it before but I read a thread, how do I read the blinking lights for instance if it's code 34 ?
I really appreciate your responses, thank yu!

TommyB50 09-20-2014 11:28 PM

Pulled the codes... 12 and 13
Coolant temp sensor and MAF

on my way to get a coolant temp sensor now, would that cause the maf to throw a code?


Thanks Tom

cadillacdude1975 09-21-2014 12:50 AM

unless you or someone else has been messing with the MAF, its more than likely corroded wiring. if the MAF is out of spec, the ecm will kill the fuel pump. thats why its not running. i'd bet dollars to donuts.

TommyB50 09-21-2014 05:28 AM

Haven't messed with it..was going to test it with the volt meter...



The real question is how do yu change this temp sensor without taking off the front of the motor??

TommyB50 09-25-2014 02:47 AM

Coolant temp sensor seemed to fix it, runs good now, but still dealing with a high idle issue, no luck with the idle screw...anything else ? It idles high and sometimes jump from 1500-1700 at a stop.

Salinas831 06-16-2020 03:18 PM

TPS is code 43. I replaced it and now my 94 d21 won't even start.

Foul_Mouth 06-16-2020 03:24 PM

Will it run if you shoot starting fluid into the throttle body?


All times are GMT. The time now is 10:30 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.