Infamous Nissan - Hardbody / Frontier Forums

Infamous Nissan - Hardbody / Frontier Forums (http://www.infamousnissan.com/forum/index.php)
-   Hardbody Forum (D21) (http://www.infamousnissan.com/forum/forumdisplay.php?f=21)
-   -   Mass Air Problem (http://www.infamousnissan.com/forum/showthread.php?t=45687)

fillpot 07-21-2021 04:26 PM

Mass Air Problem
 
Guy's new to the forum, I'm from a small town in South Alabama (Atmore) been around cars and such for I guess 35 years I'm 51 now but came into something I'm not sure about, I have a 1997 Nissan d21 and for a while now been having a problem with the truck stumbling, want accelerate, idle for a few seconds and die, went ahead and replaced the fuel pump for piece of mind it's got 200k with one rebuild and it didn't fix nothing , so got to looking around and there were no bolts holding on the mass air sensor so got some bolts plugged it up and killed the motor now after two new mass air sensors it's doing the same
thing, I have searched up and down the web for a fix but nothing has worked, no vacum leaks, no distibuter problems, broke wires etc, unhook the mass air sensor and it will run fine up to 2500 when it hits the fail safe, I've had a bunch of these little trucks threw the years and never ran into this before, plugs look good as well as wires, I'm sure someone has ran into this before, THANKS in advance!

Deerhurst 07-21-2021 05:53 PM

You are in limp mode. Pull codes. The 97 is also OBD compliant. Makes it easy.

fillpot 07-21-2021 09:00 PM

Forgot to add that Iíve tried two scanners and canít either one to read, Thanks

Deerhurst 07-21-2021 09:49 PM

Pull codes the old fashioned way then. Count the blinky lights.



If you don't already have a copy look for SiFi or JP. They can supply you with a PDF copy of the FSM.

fillpot 07-22-2021 12:34 AM

Cool I'm on it THANKS!

Deerhurst 07-22-2021 02:31 AM

Good luck! Let us know what you find!

fillpot 07-22-2021 03:34 AM

Thanks I will, btw while Iím here I have a 2003 Nissan Frontier 3.3 supercharged thatís going to need some lifters any recommendations on a brand, sorry to get off my main topic!

Deerhurst 07-22-2021 03:43 AM

It uses the same lifters as the VG30. Lifters on these engines are a PITA. Sometimes it's impossible to make them quiet. I'd just go with a recognized brand.





If you ever want to get rid of that blower, keep me in mind! I'm hoping to supercharge my VG33. I need all the supercharger specific stuff under the hood. Injectors, belt tensioners, blower, stuff like that.

fillpot 07-26-2021 12:20 AM

Quote:

Originally Posted by Deerhurst (Post 551490)
It uses the same lifters as the VG30. Lifters on these engines are a PITA. Sometimes it's impossible to make them quiet. I'd just go with a recognized brand.





If you ever want to get rid of that blower, keep me in mind! I'm hoping to supercharge my VG33. I need all the supercharger specific stuff under the hood. Injectors, belt tensioners, blower, stuff like that.

Man I should ever sine I've had the truck It's had a bad knock sensor don't think it's seen boost in a long time, weak and loves gas lol!

fillpot 08-13-2021 03:09 PM

Guy’s just pulled my seat to count the flashes and it looks like my computer doesn’t have the lights? Is there a cover or something

etx97xe 08-13-2021 06:12 PM

96-97
 
96-97 have odbII not odbI

I have a 97 4cyl automatic.
The good there the last year the truck was made. So most of the issues are fixed.

The bad the last 6 months or so of production they literally pulled parts from around the world to finish up the last hardbody trucks.

My 97 has a floor shifter that looks like it came from a sentra. But most i have seen have on the column shifter.

As far as the issue your having. Sounds like a mass air flow issue or idle speed control or electrical wiring that runs between the valve cover and the throttle body. That big-mass of wires with electrical tape covering it.
I had a idle issue and when you grabbed that wire harness it would get better.
Maybe a bad computer. But probably not.
Try to use a odb2 scanner see if it works. :confused:

fillpot 08-13-2021 07:51 PM

Thanks buddy but that is one of my problems, I've had two scanners and both will not log on, they work on everything else, one was a snap on and it's a fine one. THANKS!

PorknBeans 08-13-2021 08:00 PM

You’ll need to check to pins on the OBDII Data Port. Maybe they’re not fully connected, damaged or have bent pins.

When a code reader is connected to the port. Power is supplied to the scanner by the port. But if there isn’t any data presented on the scanner’s screen. You’ll need to check the pin outs to see if there’s an issue within the port or wire terminations.

And just for information, OBDI stopped in 1995, but has the red & green l.e.d.’s. 1996 and on, has the OBDII with the 16-pin data port for the code reader to connect up to.

XoXSciFiGuy 08-14-2021 06:25 AM

Quote:

Originally Posted by PorknBeans (Post 552129)
Youíll need to check to pins on the OBDII Data Port. Maybe theyíre not fully connected, damaged or have bent pins.

When a code reader is connected to the port. Power is supplied to the scanner by the port. But if there isnít any data presented on the scannerís screen. Youíll need to check the pin outs to see if thereís an issue within the port or wire terminations.

And just for information, OBDI stopped in 1995, but has the red & green l.e.d.ís. 1996 and on, has the OBDII with the 16-pin data port for the code reader to connect up to.

On some of the 96-97s, you have to hold the scanner connector by hand, tighter...into the scanner connector on the truck. Push a little more firmly and hold it there. Then it will connect sometimes. I have heard this from a couple of late model owners.

fillpot 08-14-2021 02:51 PM

Thanks guys going to mess with it this afternoon

fillpot 09-04-2021 12:37 AM

Hey guy's finally getting back around to the truck, can ya'll tell me what the little silver deal with two wires that is bolted to the bottom of the air filter housing is, both wires are broke, probably doesn't matter much but just bothers me lol, hope this makes since, btw still cant get the scanner to log on, looks like it's going to be the hard way. THANKS!

diosmuertos 09-04-2021 02:29 AM

Quote:

Originally Posted by fillpot (Post 552839)
Hey guy's finally getting back around to the truck, can ya'll tell me what the little silver deal with two wires that is bolted to the bottom of the air filter housing is, both wires are broke, probably doesn't matter much but just bothers me lol, hope this makes since, btw still cant get the scanner to log on, looks like it's going to be the hard way. THANKS!

that's the intake air temp sensor. It'll run super rough without it. I've been fine with the cheapo replacements from Rockauto

fillpot 09-04-2021 02:31 AM

Good deal thanks, you think this could have any thing to do with the mass air killing the engine when I plug it in

PorknBeans 09-04-2021 05:54 AM

If you do the continuity test on the Air Intake Temperature sensor. The test will tell you if the component is good or not. I inadvertently removed the air cleaner housing many years ago and didn’t know it was mounted on the underside of the housing and broke both wires. I soldered them back together and it has worked since that repair was done in 1998/1999.

Looking at the schematic for the Engine Control components. The IAT doesn’t appear to affect the MAF sensor, at least directly. I feel it has an affect on engine performance. But the description of the IAT states that the IAT is for “Onboard Diagnostics” only. If the circuit of the component is closed(good part). There’s no effect on engine performance. Open circuit(bad component) affects engine performance.


https://i.postimg.cc/5HyH2djC/4781-B...169-AA2-EF.jpg

https://i.postimg.cc/8JrjLRRk/F3-BEC...-F5-FE63-B.jpg

https://i.postimg.cc/yJDdzmrh/E743-D...60-A3-C3-B.jpg

https://i.postimg.cc/VSXj8PhW/8-CB69...73-A30-FB4.jpg

fillpot 09-07-2021 10:41 PM

Ok good deal, thanks buddy!

fillpot 09-25-2021 02:44 AM

Still no luck guy's any good nissan mechanics in the Southeast lol. THANKS!


All times are GMT. The time now is 12:48 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.