Infamous Nissan - Hardbody / Frontier Forums

Infamous Nissan - Hardbody / Frontier Forums (http://www.infamousnissan.com/forum/index.php)
-   Early Frontier Forum (D22) (http://www.infamousnissan.com/forum/forumdisplay.php?f=20)
-   -   Codes for Park Switch and Transmission Range Selector (http://www.infamousnissan.com/forum/showthread.php?t=44577)

jp2code 08-18-2020 11:07 AM

Codes for Park Switch and Transmission Range Selector
 
I have a 2000 Xterra (same electronics as the 2000 Frontier).

It was throwing a P1706 Park Neutral Position Switch (PNP Switch) Circuit Malfunction code every once in a while.

I was not able to locate an electrical wiring diagram that indicates where the plug is in the engine bay for the PNP Switch, so I just bought another one. It turns out the plug is up in the engine bay on the Passenger's side along the firewall.

I got the old PNP Switch out by disconnecting the shifting cable, pushing the selector all the way to one side, and wiggling the part out. Similarly, the new PNP Switch went back into place by wiggling it around in the area until it seated, and then I reconnected the shifting cable to the automatic transmission.

I followed this video, but my transmission was still in the truck:



Now, I get a new code: P0705 Transmission Range Sensor Circuit Malfunction. The fix for P0705 is the same as for P1706, replace the PNP Switch. The switch is still good, so I know that isn't the issue.

Everything works fine (reverse lights work, engine still cranks, no irregular shifting, or delayed engagement). I just have the Malfunction Indicator Lamp (MIL) to contend with.

What do I need to do to make the code go away? Is there a special way that the PNP Switch needs to be inserted? The electrical plug-in the engine compartment is busted on the Engine Harness side, so the original PNP Switch probably wasn't even bad - just a poor connection.

I'm hoping that someone more knowledgeable than me can provide insights.

jp2code 08-19-2020 11:06 AM

A friend pointed me towards this AT section of the Service Manual:

https://i.imgur.com/IRX14TP.png

I haven't had a chance to try this, but it looks like something I should be able to do. I noticed last night that my Reverse Lights do not turn on, so this needs to be fixed.

SBJ 08-24-2020 12:20 AM

Sorry, I just saw this thread. It is easy enough to crawl under there and adjust the switch position if you need. JP, do you have a code reader that does live data? Some of them will tell you what position the switch is in, so you could put it in reverse and see if it changes from park to reverse on the scanner at the same time. On of my scan tools does it, although it only differentiates between neutral and drive...neutral is for park and neutral and drive is for everything else. Still, you'd be able to see it change when you go from park to reverse. I would bet it's probably just out of adjustment and that's why the reverse lights don't come on. You could always turn the key on and see if the lights come on in park or neutral instead. BTW, I did this same job on a 2000 or 2001 Xterra a few years back. That wiring harness is a real fucker to get in and out of there. I had to use a piece of string to fish it through and make sure it was routed correctly.

I'd probably consult the wiring diagrams and go after the connectors first, since they are up front by the battery. Figure out which pins are supposed to be be open/closed in each gear and go from there. A basic multimeter is all that's needed to test it. I don't believe there's any sort of relay in between the switch and the backup lights, but don't quote me on that.

jp2code 08-24-2020 03:55 AM

Thanks SBJ. Yeah, I sliced both hands up pretty good fishing that wiring harness up over the transmission and to the connector. I was so happy when I got it all bolted in place, and I was so frustrated when I drove it the first time and got a new Check Engine code.

The manual sounded vague, but I was able to get it into Neutral, crawl back under the truck, take the linkage off, rotate the shift lever to straight Up and Down, and reinstall the linkage. That error code went away, and now my backup lights come on when I shift into Reverse.

I still get the P0325 Knock Sensor error code about once a week. I find it hard to believe that the Knock Sensor would only be faulty some of the time, so I suspect either poor wiring or some other issue with the engine is causing the ECU to think it is the Knock Sensor that is messed up (like an EGR valve malfunction).


All times are GMT. The time now is 08:55 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.